"The world is round because there are not supposed to be any borders."
More pages: 1 2
New drivers
Monday, January 17, 2005 | Permalink

New Catalyst drivers have been released bringing it up to version 5.1. New Linux drivers have been released as well bringing it on par with the Windows driver in terms of features. As they now fully support GLSL all my recent OpenGL demos now work in Linux as well.

Name

Comment

Enter the code below



Jonathan
Sunday, January 23, 2005

Framework2 still exhibits the "conflicting types" problem (downloaded a couple of minutes ago).

Easily fixed by adding appropriate #define __glext_h_'s, but thought you may like to know.

Humus
Monday, January 24, 2005

On what system is that? I'm not seeing any such problems.

I'm getting the conflicting types problem
Tuesday, January 25, 2005

Gentoo 2.6.10, ATI drivers 8.8.25, Metaballs demo:

g++ -Wall -ansi -DLINUX -DNO_TEX3D -DNO_PNG -O2 -ffast-math -fomit-frame-pointer
./Main.cpp ../Framework2/Math/Vector.cpp ../Framework2/App.cpp ../Framework2/Op
enGL/OpenGLApp.cpp ../Framework2/Linux/LinuxBase.cpp ../Framework2/Globals.cpp .
./Framework2/CPU.cpp ../Framework2/DisplayMode.cpp ../Framework2/Menu.cpp ../Fra
mework2/OpenGL/glExtensions.cpp ../Framework2/Renderer.cpp ../Framework2/OpenGL/
OpenGLRenderer.cpp ../Framework2/Imaging/Image.cpp ../Framework2/Util/String.cpp
../Framework2/Util/Font.cpp ../Framework2/Util/Config.cpp ../Framework2/Util/To
kenizer.cpp ../Framework2/Util/IsoSurface.cpp -o MetaBalls -L/usr/X11R6/lib -lGL
-lXxf86vm -L/usr/lib -ljpeg
In file included from ../Framework2/OpenGL/OpenGLRenderer.h:19,
from ../Framework2/OpenGL/OpenGLApp.h:20,
from Main.h:1,
from Main.cpp:1:
../Framework2/OpenGL/glExtensions.h:48: error: conflicting types for `typedef
long int GLintptrARB'

If you've got assistance, I'd appreciate it because your demos like extremely nice!

Jonathan
Tuesday, January 25, 2005

Identical to previous comment.

Humus
Sunday, January 30, 2005

Ok, try downloading it again now. It should be fixed now.

feras
Saturday, November 26, 2005

can u give full ver of yr flag project

JOTACODINA
Monday, May 15, 2006

QUIERO DRIVERS PARA NeHe

Poll
Monday, May 15, 2006

Gentoo 2.6.10, ATI drivers 8.8.25, Metaballs demo:

g++ -Wall -ansi -DLINUX -DNO_TEX3D -DNO_PNG -O2 -ffast-math -fomit-frame-pointer
./Main.cpp ../Framework2/Math/Vector.cpp ../Framework2/App.cpp ../Framework2/Op
enGL/OpenGLApp.cpp ../Framework2/Linux/LinuxBase.cpp ../Framework2/Globals.cpp .
./Framework2/CPU.cpp ../Framework2/DisplayMode.cpp ../Framework2/Menu.cpp ../Fra
mework2/OpenGL/glExtensions.cpp ../Framework2/Renderer.cpp ../Framework2/OpenGL/
OpenGLRenderer.cpp ../Framework2/Imaging/Image.cpp ../Framework2/Util/String.cpp
../Framework2/Util/Font.cpp ../Framework2/Util/Config.cpp ../Framework2/Util/To
kenizer.cpp ../Framework2/Util/IsoSurface.cpp -o MetaBalls -L/usr/X11R6/lib -lGL
-lXxf86vm -L/usr/lib -ljpeg
In file included from ../Framework2/OpenGL/OpenGLRenderer.h:19,
from ../Framework2/OpenGL/OpenGLApp.h:20,
from Main.h:1,
from Main.cpp:1:
../Framework2/OpenGL/glExtensions.h:48: error: conflicting types for `typedef
long int GLintptrARB'

If you've got assistance, I'd appreciate it because your demos like extremely nice!

More pages: 1 2